Results 1 to 5 of 5

Thread: Problem with Applian Miniport - cannot uninstall.

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Feb 2013
    Rep Power

    Unhappy Problem with Applian Miniport - cannot uninstall.

    Hello there, I downloaded the trial a few days back, and it seemed to work for its intended purpose, however, today some of my forced IP-related configurations stopped working (tunneling mainly).

    I quickly noticed that the "Applian Miniport" Device under Network Adapters in Device Manager (devmgmt.msc) had an asterisk symbol next to it, so I uninstalled RMC 4.4.5, but the Applian Miniport still decided to stay behind.

    Disabling the device does not seem to have any effect at all.
    Even RMC still worked when it was disabled.

    So i right-clicked the device directly, chose uninstall, clicked yes, sometimes ticking the "Delete the driver software for this device" whenever it chooses to appear, its random, and nothing happened. I did that a few times around, and it still refuses to leave my computer.

    I've tried EVERYTHING I can come up with, including several programs that are made especially to remove "bad" drivers. With administrator rights.

    That includes trying to update the driver so the device would start working again for easy uninstall, with RMC installed and without.

    The hardware Ids part of driver details says "nt_appliandmp" but googling that wont give me any good info.

    In both cases it either gives Code 31 (not working properly because windows cannot load the drivers required), or Code 19 (Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. To fix this problem you should uninstall and then reinstall the hardware device.)

    Also tried various methods in Safe-Mode without networking, hoping that the device wouldn't get loaded and it'd be easy to get rid of. No success.

    Only thing I can think of from this point on, is deleting it by hand from registry but I've no expertise on that.

    I'm running Windows 7 Build 7601 64-bit fully updated.
    Using comodo firewall but I uninstalled that at one point as well just to take a shot in the dark.

    The device is using only one driver file: C:\windows\system32\DRIVERS\appliand.sys , file version by Applian Technologies 2011, not digitally signed.

    It can't be this hard to remove something that you guys made?
    Last edited by TeeSax; 02-07-2013 at 04:51 PM. Reason: Extra infos

Similar Threads

  1. Applian miniport error
    By shiggityswaa in forum General Discussion
    Replies: 2
    Last Post: 04-28-2012, 03:06 PM
  2. Problem with uninstall
    By Immadiyah in forum General Discussion
    Replies: 1
    Last Post: 10-04-2011, 04:27 AM
  3. Jaksta uninstall problem
    By floyd6 in forum Replay Media Catcher
    Replies: 5
    Last Post: 10-04-2011, 04:24 AM
  4. Problem buying with credit card on applian site
    By Ed_N in forum General Discussion
    Replies: 1
    Last Post: 06-20-2011, 08:58 PM
  5. applian miniport 4?
    By Bill in forum Replay Media Catcher
    Replies: 0
    Last Post: 01-09-2011, 12:50 PM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
About these forums...
Applian Technologies makes these discussion forums available for our customers to assist other users. We do read this content and appreciate all your suggestions and comments. If you need technical support or customer service, please visit the links to the right.
Let's Be Friends