I don't use this too much but wanted to record something off YouTube. I'm using Win8 64bit and I had a couple errors and followed the FAQ instructions and ended up getting my video to record just fine. However, I went to record another video off YouTube (totally different video) and it recorded it just fine but with the SAME name as my previous video (except it added a "- 1" after it). I tried again and got a "- 2". I even noticed that when I went to a higher quality, I got the same name again but with the .mp4 extension rather than the flv extension.

I looked in the FAQ and back a few months here but didn't see anything where anybody else was seeing this. Just wondering if anybody else has seen this and if anybody knows how to fix it? FYI, the 2nd video was a YouTube video embedded into a website. When I clicked the "view in YouTube" button and went directly to YouTube THEN it did name it correctly. Just kinda weird how the first video was directly off YouTube and the 2nd video I tried was embedded in a webpage but named it the same. Then when I went directly to YouTube it named it correctly.