View Full Version : Videos that doesn't stream if Real Media Catcher is recording.

08-29-2008, 11:30 AM

I tried to capture streaming videos from the following site :
www.recordme.tv (http://www.recordme.tv/)
... using Real Media Catcher 3.0 (built Aug 21 2008).

This is a site that you can ask for recording French Digital TV programs, and once these programs have been broadcast, you can view them on your computer using Adobe Shockwave Flash (probably on RMTPT protocol) during 15 days.

The strange thing is, if you open Real Media Catcher for recording the stream, you are no longer to play it from the web site.
It is like if the video plug-in was aware of the existence of Real Media Catcher and refused to play if Real Media Catcher is recording.

Of course, as the video cannot play, you cannot record the video with RMC either.

Is somebody aware of this kind of problem ?

08-29-2008, 02:31 PM

I know your problem!
I have exact the same problem with the following Website.
Itīs the website from "THE" german News-Show "Tagesschau".
My Steps:
1. I bookmark the Website with the Flash-Video.


2. I delete the temorary Internet Cache.
3. I start the Replay Media Catcher.
4. I open my browser with a blank Startpage.
5. I open the Bookmark from point "1"
6. And then I see the "Loading-Circle"....
7. And the video dont start!!!!!
After that...
8. I close the Replay Media Catcher
9. I reload the website from my bookmarks
10. After two seconds the video starts.

The video dont start, when the Replay Media Catcher is running!!!
The answer from the support:
"You can select the Windows Media Player at this site!
Try this option for download the show!!!"
That was not my problem!
I would like to download the FLV-File!!!



08-29-2008, 11:04 PM
I just tried the recording on your Tagesschau (http://www.tagesschau.de/multimedia/video/video356346_bcId-tt744_ply-internal_res-flash256_vChoice-video356346.html) site, with exactly the same result as you : the video doesn't start when Replay Media Catcher is recording.

For me, maybe using the Windows Media Player option could have been a solution.

The problem is, on the web site www.recordme.tv (http://www.recordme.tv/), there is no option like using Windows Media Player :
FLV is the only available format.


09-01-2008, 10:55 PM
Have you tried web stream dumper? Tools | settings | tick box. I have to restart RMC after turning on Web Stream Dumper. Then open browser to the video and let it run the whole show. RMC captures everything that was viewed in that browser.

09-02-2008, 02:32 PM
Have you tried web stream dumper? Tools | settings | tick box. I have to restart RMC after turning on Web Stream Dumper. Then open browser to the video and let it run the whole show. RMC captures everything that was viewed in that browser.


Thank you very much for your answer.

I just tried RMC with Web Stream Dumper.
Unfortunately, this doesn't change anything : even like that, the video doesn't play as long as RMC is recording. I need to stop recording for being able to have the video playing in the browser.

By the way, it doesn't make sense to restart RMC after turning on Web Stream Dumper : the state of the Web Stream Dumper option is not saved after quitting and relaunching the RMC application.


09-10-2008, 06:49 AM

I just want to add the following concerning the site "recordme.tv (http://www.recordme.tv/)" from which I cannot download videos because videos cannot play if Real Media Catcher is recording.

It looks like (from my network analysis) that videos from this site are streamed using a software server named "Wowza Media Server Pro (http://www.wowzamedia.com/products.html)". You can read this page (http://www.wowzamedia.com/products.html) for knowing the features of this server.

If you look under the "Secure" tab, you will see the following :

Wowza Pro offers a complete suite of security measures to guard your streamed content form intrusion, unauthorized diversion and ripping. In addition to conventional measures like trusted domains/IP addresses and encrypted transport tunneling with RTMPE/RTMPS, Wowza's unique SecureToken, an encrypted challenge/response methodology, provides strong protection against threats from streaming media ripping products like Replay Media Catcher.

I think that the Replay Media Catcher developer team is going to have a challenge, there ...


Tasha Heinlein
09-10-2008, 11:17 AM
When I tested this, I was able to capture the videos. Can you give me a specific video that you are having problems capturing?

Best Regards,

Tasha Heinlein
Applian Technologies, Inc.

09-10-2008, 12:19 PM
When I tested this, I was able to capture the videos. Can you give me a specific video that you are having problems capturing?

Best Regards,

Tasha Heinlein
Applian Technologies, Inc.

Due to the nature of the site, this would need me to give login informations of my account. I will think about that, but...

...anyway I am sure of what I said :
I tried recording from five different OS/computers (including Intel or AMD processors, with Windows XP or Windows Vista, 32 bits or 64 bits, sometimes inside virtual machines, and using Internet Explorer 7 and Mozilla Firefox). Some of these configurations were very naked about drivers, peripherals and installed software.
The result was the same everywhere : no recordings possible because videos doesn't play inside the browser if RMC is recording.

I think about something...
Maybe this is very paranoid, but what about if something was intentionally made for making YOU, in Applian (for example basing on IP or location or anything else) being able to record, and US (living in France and thus being mostly the only people really interested on this recordings) not able to do anything with RMC on this site ?
On the streaming site point of view, as it is evident that they are specifically aware of the need to fight against RMC, this would be a very good way to make you not able to see the problem, and thus not able to test anything about it.

... and we know (from another site that I also asked you earlier to test) that it is possible to distinguish between us on location basis.


09-11-2008, 10:53 AM
Since the Web Stream Dumper setting is not saved between launches, then I would say that has no effect on my ability to record.

I am able to record videos from this site using Replay Media Catcher. Here is one example of a preview I was able to record. I signed up for a free account but I don't believe one is needed to view this URL
I am able to wtch what I am recording.

09-11-2008, 12:01 PM

I can record this video too, using RMC, without problem.

But this is an "open" program preview, not the result of asking for a record, and apparently these previews don't have the same restrictions.

I checked again, just after, one of the three programs that are available on my account on the site and that I asked before (two of them are going to expire very soon), and I am still unable to record these programs.

Just in case it would matter : ask for a movie rather than for a short program like weather report. Just in case all programs wouldn't have the same restrictions.


09-12-2008, 04:57 PM
I can reproduce your problem. I have three saved programs and all refuse to play if Media Catcher is recording. Press the "Stop Recording" button, then the streams play. So, you are not crazy. :D Or we both are. :eek:

Here is a new twist. This was not successful but proves interesting. I added application/x-fcs to the MIME types because that is what the server is sending. Then I followed exactly Applians video instructions for capturing imeem with Web Stream Dumper. No success. Until...

If you lower the Web Stream Dumper minimum dump size from 400k to 100k, then Web Stream Dumper begins to capture. It will record lots of 100k -> 125k .tmp files in succession. That's why I added application/x-fcs, to see if that helped Media Catcher recognize a stream. But the tmp files are unplayable.

One interesting bug in Media Catcher, is that after a tmp file is saved and the green check appears, indicating a stream is captured and saved, in the GUI two or more already saved tmp files' sizes will continue to increment upward in size. After the complete stream is viewed however, none of the dozens of tmp files are playable. The one byte hex view is gibberish. Or at least no hex views contain FLV header or metadata info.

09-12-2008, 10:40 PM
Yes, I also made some steps similar to yours, especially using the "Web Stream Dumper" options, and lowering the dump size, with exactly the same result as you : a lot of "tmp" files that are useless for reading.

A network analysis using Wireshark (http://www.wireshark.org/) (formerly Ethereal) let me thinking that the "FLV" header is not even present in the stream. But I don't know the protocol, so maybe this is normal.

Otherwise, it looks like that the plug-in corresponding to this stream is "HTTP Media Streams" (because if I disable only this one, the video can play normally, but of course it still can't be captured ; also, the stream dumped by Wireshark is identified as HTTP).

Wireshark shows also that, with "normal" use or Real Media Catcher, the streaming begins anyway, but seems to be abruptly interrupted after a very short time.

I think that the site uses Wowza Media Server Pro (http://www.wowzamedia.com/products.html) configured with its "securetoken" template. This template verifies using an encrypted exchange that the used player is an authorized player. There is probably also some server side scripting (Wowza Media Server Pro seems to allow that) that shutdowns completely all connections to the used IP if any unknown player tries simultaneously to connect to the same stream.

The used player is JW FLV Media Player (http://www.jeroenwijering.com/?item=JW_FLV_Player) (this web address is present inside the player). You could also read this (http://www.jeroenwijering.com/?item=HTTP_Video_Streaming) on the web site of this player.

Admins note: Thanks for the information, though we do like to refer people to our own Free FLV Player (http://applian.com/flvplayer/index.php)instead... :-)

11-26-2008, 09:02 AM
Yo !

I have the same problem as Gingko.

Here is what I found :

The config file is a URL like

It contains the following data :


This confirms the fact that a secure token is used.

The URL http://www.recordme.tv/playerplaylist-20410657-20081126135553-523.8-1315.4 gives the following data :

<playlist version="1">
<meta rel="type">video</meta>
<meta rel="start">523.8</meta>
<meta rel="end">1315.4</meta>
<annotation>00:08:43-00:21:55 Duration 00:13:11</annotation>

So I guess the file that is used for the source is

Unfortunately, I don't know witch software is able to read / rip it :(

If you have more information, please give me an update !