View Full Version : FIX: Windows 7 no audio issue

11-08-2009, 09:19 AM
So after messing with Windows 7 a LOT I believe I have found the way to fix the no audio problem so many of us are having. The issue seems to be that the default audio device in Windows gets changed from "what you hear" to something else. In my case, this was because I installed other devices that have sound capabilities. So at first Replay worked, and then it didn't. If it never worked for you, then you probably never had this setting in windows 7 right.

Here are the steps to fix:

1. Open "control panel"
2. click "hardware and sound"
3. click "manage audio devices"
4. click "recording tab"
5. you need to make "what you hear" the default device. If you dont see a green checkmark next to it. select it and click "set default"
6. In my case, this showed as "unavailable". In order to make it available, I needed to click on the device that WAS the default and turn it off. (in my case, "analog mix"). Select the device, click "properties", then at the drop down at the bottom, chose "dont use this device".
7. You should now see that "what you hear" is availble. Assuming so, select it and chose "set default".

In my case, this fixed the problem.

Hope this helps. Good luck.

11-08-2009, 07:38 PM
Oh. thank you so much for this one!


11-10-2009, 01:42 PM
5. you need to make "what you hear" the default device. If you dont see a green checkmark next to it. select it and click "set default"

I made it to Step 5, but in my recording tab, there is only two options, both microphones. I have it set to show disabled and disconnected devices, but nothing else shows up. Any other ideas??

11-11-2009, 07:03 AM

11-13-2009, 09:50 PM
Hi, after a few hours of reading and installing and uninstalling I have figured out how to make the "audio driver" included with RM to function in windows 7. I received the "Active X" error everytime I installed and was not an issue. Here is what I did to make it work...

Uninstall any version of RM that is currently on the machine and reboot the machine.

Find the RM.exe to install and right click on the file and click on "properties." Click on the "compatiblity" tab and and check "run this program in compatiblity mode" select "windows xp service pack 2"

Next check the box that says " run this this program as an administrator."
Next click on the "security" tab. Under "group or user names" select "administrators" and then click apply.

Run the installation.

Do not launch the program.

Find the icon on the desktop and right click on it and select "properties" and reselect the exact same options listed above and click apply and ok. I belive the administrator setting is the key to making it work.

Start RM and click on settings. Make sure the "audio driver" is selected.

I hope this will help someone and they will not have to spend all the time I have to make this work on my computer.