View Full Version : Replay Music Error in Windows7: Failed to register COM (activeX) comtrol c:\programfiles\replaymusic\atl.dll

09-14-2009, 12:02 PM
Hi i get the following error when installing

Failed to register COM (activeX) comtrol c:\programfiles\replaymusic\atl.dll
failure code returned by dllregisterservice(0)

Any ideas?

I am running windows 7 64 bit

Just got it working but its not a solution. If i have internet explorer open the program loads without any problem.:confused:

09-14-2009, 06:55 PM
Is there a compatibility issue with Windows 7?


09-14-2009, 11:38 PM
Is there a compatibility issue with Windows 7?
It works fine for me in Windows 7 x64.

Cheryl Wester
09-15-2009, 09:26 AM
See if a reinstall of the program does the trick for you.

10-28-2009, 03:10 PM
i had the same error (failed to register atl.dll) when installing on a fresh windows 7 x64 machine. Replay Music launches but doesn't detect any sound - I am using Pandora. An uninstall/re-install did not resolve the issue. Windows media player does have the plugins. Hellp!

Cheryl Wester
10-28-2009, 05:05 PM
Please contact tech support for this as more info will be needed. Also, we will need a copy of your log file. The developer is aware of this happening in some cases.

11-03-2009, 05:52 PM
Hi, I'm having a similar problem. I have just upgraded to windows 7 64 bit version and get the same error when trying to install.

I can use replay afterwards despite the error, whereby it can record in chrome but not in explorer. After closing replay music and reopening it however, I get the message failed to load audio driver and it wont open again.

I have tried reinstalling but still get the same problem. Also, when uninstalling replay music I get a message which tells me that it can't uninstall some parts as they are still open, despite the fact that replay is nowhere to be found in the task manager.

I had no problems when running vista 32 bit on the same laptop.

How does one get a log file to post to the tecchies, I've not done that before?

11-04-2009, 09:54 AM
I seem to have got it to work now. I got windows to apply compatibility settings when installing and then set replay to work in xp compatibility mode. Seems to work fine now.

Mike Christensen
11-05-2009, 03:18 PM
Just to let everyone know, a newer version of Replay Music is coming out soon that will no longer use that atl.dll file so that error should no longer come up for the users having that issue.